import Foundation
let pattern = #""([A-Z0-9-_]*\/[A-Z0-9-_]*)":\s"([\,<>=-~*.@A-Z0-9]*)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
"silex/silex": "*",
"pomm/pomm-service-provider": "*@dev",
"twig/twig": "*",
"symfony/yaml": "~2.6",
"incenteev/composer-parameter-handler": "~2.1",
"sanpi/twitter-bootstrap-installer": "~1.1"
"silex/web-profiler": "*",
"atoum/atoum": "~1.0",
"behatch/contexts": "~2.0",
"behat/mink-extension": "~2.0",
"behat/mink-goutte-driver": "*"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}