use strict;
my $str = '"silex/silex": "*",
"pomm/pomm-service-provider": "*@dev",
"twig/twig": "*",
"symfony/yaml": "~2.6",
"incenteev/composer-parameter-handler": "~2.1",
"sanpi/twitter-bootstrap-installer": "~1.1"
"silex/web-profiler": "*",
"atoum/atoum": "~1.0",
"behatch/contexts": "~2.0",
"behat/mink-extension": "~2.0",
"behat/mink-goutte-driver": "*"';
my $regex = qr/"([A-Z0-9-_]*\/[A-Z0-9-_]*)":\s"([\,<>=-~*.@A-Z0-9]*)"/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}