// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)"([A-Z0-9-_]*\/[A-Z0-9-_]*)":\s"([\,<>=-~*.@A-Z0-9]*)""#).unwrap();
let string = "\"silex/silex\": \"*\",
\"pomm/pomm-service-provider\": \"*@dev\",
\"twig/twig\": \"*\",
\"symfony/yaml\": \"~2.6\",
\"incenteev/composer-parameter-handler\": \"~2.1\",
\"sanpi/twitter-bootstrap-installer\": \"~1.1\"
\"silex/web-profiler\": \"*\",
\"atoum/atoum\": \"~1.0\",
\"behatch/contexts\": \"~2.0\",
\"behat/mink-extension\": \"~2.0\",
\"behat/mink-goutte-driver\": \"*\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}