using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""([A-Z0-9-_]*\/[A-Z0-9-_]*)"":\s""([\,<>=-~*.@A-Z0-9]*)""";
string input = @"""silex/silex"": ""*"",
""pomm/pomm-service-provider"": ""*@dev"",
""twig/twig"": ""*"",
""symfony/yaml"": ""~2.6"",
""incenteev/composer-parameter-handler"": ""~2.1"",
""sanpi/twitter-bootstrap-installer"": ""~1.1""
""silex/web-profiler"": ""*"",
""atoum/atoum"": ""~1.0"",
""behatch/contexts"": ""~2.0"",
""behat/mink-extension"": ""~2.0"",
""behat/mink-goutte-driver"": ""*""";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}