import Foundation
let pattern = #"(?<req_ip>[\d\.]+)\s(?<req_unk1>[\w\-]+)\s(?<req_unk2>[\w\-]+)\s\[(?<req_ts>\d+\/\w+\/\d+\:\d+\:\d+\:\d+\s\+\d+)\]\s\"(?<req_full>.+?)\"\s(?<req_status>[\d\-]+)\s(?<req_bytes_in>[\d\-]+)\s\"(?<req_referrer>.+?)\"\s\"(?<req_ua>.+?)\"\s\"(?<req_cookie>.+?)\"\s\"(?<req_waf_info>.+?)\"\s\"(?<req_customfield>.+?)\""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1.1.1.1 - - [05/May/2015:13:23:13 +0000] "HEAD /www.arl.com/path/to/file.php HTTP/1.1" 200 265 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)" "-" "-" "UNKNOWN""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}