re = /(?<req_ip>[\d\.]+)\s(?<req_unk1>[\w\-]+)\s(?<req_unk2>[\w\-]+)\s\[(?<req_ts>\d+\/\w+\/\d+\:\d+\:\d+\:\d+\s\+\d+)\]\s\"(?<req_full>.+?)\"\s(?<req_status>[\d\-]+)\s(?<req_bytes_in>[\d\-]+)\s\"(?<req_referrer>.+?)\"\s\"(?<req_ua>.+?)\"\s\"(?<req_cookie>.+?)\"\s\"(?<req_waf_info>.+?)\"\s\"(?<req_customfield>.+?)\"/
str = '1.1.1.1 - - [05/May/2015:13:23:13 +0000] "HEAD /www.arl.com/path/to/file.php HTTP/1.1" 200 265 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)" "-" "-" "UNKNOWN"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end