import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<req_ip>[\\d\\.]+)\\s(?<req_unk1>[\\w\\-]+)\\s(?<req_unk2>[\\w\\-]+)\\s\\[(?<req_ts>\\d+\\/\\w+\\/\\d+\\:\\d+\\:\\d+\\:\\d+\\s\\+\\d+)\\]\\s\\\"(?<req_full>.+?)\\\"\\s(?<req_status>[\\d\\-]+)\\s(?<req_bytes_in>[\\d\\-]+)\\s\\\"(?<req_referrer>.+?)\\\"\\s\\\"(?<req_ua>.+?)\\\"\\s\\\"(?<req_cookie>.+?)\\\"\\s\\\"(?<req_waf_info>.+?)\\\"\\s\\\"(?<req_customfield>.+?)\\\"";
final String string = "1.1.1.1 - - [05/May/2015:13:23:13 +0000] \"HEAD /www.arl.com/path/to/file.php HTTP/1.1\" 200 265 \"-\" \"Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)\" \"-\" \"-\" \"UNKNOWN\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}