// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?<req_ip>[\d\.]+)\s(?<req_unk1>[\w\-]+)\s(?<req_unk2>[\w\-]+)\s\[(?<req_ts>\d+\/\w+\/\d+\:\d+\:\d+\:\d+\s\+\d+)\]\s\"(?<req_full>.+?)\"\s(?<req_status>[\d\-]+)\s(?<req_bytes_in>[\d\-]+)\s\"(?<req_referrer>.+?)\"\s\"(?<req_ua>.+?)\"\s\"(?<req_cookie>.+?)\"\s\"(?<req_waf_info>.+?)\"\s\"(?<req_customfield>.+?)\""#).unwrap();
let string = "1.1.1.1 - - [05/May/2015:13:23:13 +0000] \"HEAD /www.arl.com/path/to/file.php HTTP/1.1\" 200 265 \"-\" \"Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)\" \"-\" \"-\" \"UNKNOWN\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}