// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*\/(\w+(?:\.\w+)?)[?\.]?").unwrap();
let string = "https://my.website.com/reports?ref_=kdp_BS
https://my.website.com/reports.html
https://my.website.com/subfolder/reports.html";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}