re = /.*\/(\w+(?:\.\w+)?)[?\.]?/
str = 'https://my.website.com/reports?ref_=kdp_BS
https://my.website.com/reports.html
https://my.website.com/subfolder/reports.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end