package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\/(\w+(?:\.\w+)?)[?\.]?`)
var str = `https://my.website.com/reports?ref_=kdp_BS
https://my.website.com/reports.html
https://my.website.com/subfolder/reports.html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}