#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*\/(\w+(?:\.\w+)?)[?\.]?"
Local $sString = "https://my.website.com/reports?ref_=kdp_BS" & @CRLF & _
"https://my.website.com/reports.html" & @CRLF & _
"https://my.website.com/subfolder/reports.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")