re = /page=([^&]+)&[^&]+&isOverallSearch=([^"|&]+)(?:&categoryPathFilter=([^&|"]+))?/
str = '"/search?productId=PI11940&searchTerm=steuer&page=1&pageSize=15&isOverallSearch=false&categoryPathFilter=PI11940%7C4"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end