using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"page=([^&]+)&[^&]+&isOverallSearch=([^""|&]+)(?:&categoryPathFilter=([^&|""]+))?";
string input = @"""/search?productId=PI11940&searchTerm=steuer&page=1&pageSize=15&isOverallSearch=false&categoryPathFilter=PI11940%7C4""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}