const regex = /page=([^&]+)&[^&]+&isOverallSearch=([^"|&]+)(?:&categoryPathFilter=([^&|"]+))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('page=([^&]+)&[^&]+&isOverallSearch=([^"|&]+)(?:&categoryPathFilter=([^&|"]+))?', 'g')
const str = `"/search?productId=PI11940&searchTerm=steuer&page=1&pageSize=15&isOverallSearch=false&categoryPathFilter=PI11940%7C4"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}