package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`page=([^&]+)&[^&]+&isOverallSearch=([^"|&]+)(?:&categoryPathFilter=([^&|"]+))?`)
var str = `"/search?productId=PI11940&searchTerm=steuer&page=1&pageSize=15&isOverallSearch=false&categoryPathFilter=PI11940%7C4"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}