// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?'pair'(?'d'-)(?'lcv'\w+)(?'s'\s)(?'dol'\$)(?'o'\()(?'ucv'\w+)(?'c'\)))(?'es'\s?)").unwrap();
let string = "-solutionName $(SolutionName) -solutionAbbreviation $(SolutionAbbreviation) -projectName $(ProjectName) -projectAbbreviation $(ProjectAbbreviation) -environmentAbbreviation $(EnvironmentAbbreviation) -appServicePlanAbbreviation $(AppServicePlanAbbreviation) -logicAppAbbreviation $(LogicAppAbbreviation) -serviceBusNamespaceAbbreviation $(ServiceBusNamespaceAbbreviation) -serviceBusQueueAbbreviation $(ServiceBusQueueAbbreviation) -scanAppServicePlanLocation $(ScanAppServicePlanLocation) -scanAppServicePlanSKUName $(ScanAppServicePlanSKUName) -scanAppServicePlanSKUTier $(ScanAppServicePlanSKUTier) -scanAppServicePlanNumberOfWorkers $(ScanAppServicePlanNumberOfWorkers) -hockeyAppAPIUri $(HockeyAppAPIUri) -hockeyAppAPIAuthenticationTenant $(HockeyAppAPIAuthenticationTenant) -hockeyAppAPIAuthenticationAudience $(HockeyAppAPIAuthenticationAudience) -hockeyAppAPIAuthenticationClientId $(HockeyAppAPIAuthenticationClientId) -hockeyAppAPIAuthenticationSecret $(HockeyAppAPIAuthenticationSecret) -hockeyAppAPIPollingInterval $(HockeyAppAPIPollingInterval) -scanQueueNamespaceKind $(ScanQueueNamespaceKind) -scanQueueNamespaceSkuName $(ScanQueueNamespaceSkuName) -scanQueueNamespaceSkuTier $(ScanQueueNamespaceSkuTier) -scanQueueNamespaceLocation $(ScanQueueNamespaceLocation) -scanQueueNamespaceAuthorizationRulesLocation $(ScanQueueNamespaceAuthorizationRulesLocation)";
let substitution = "${pair}\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}