const regex = /(?'pair'(?'d'-)(?'lcv'\w+)(?'s'\s)(?'dol'\$)(?'o'\()(?'ucv'\w+)(?'c'\)))(?'es'\s?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?\'pair\'(?\'d\'-)(?\'lcv\'\\w+)(?\'s\'\\s)(?\'dol\'\\$)(?\'o\'\\()(?\'ucv\'\\w+)(?\'c\'\\)))(?\'es\'\\s?)', 'g')
const str = `-solutionName \$(SolutionName) -solutionAbbreviation \$(SolutionAbbreviation) -projectName \$(ProjectName) -projectAbbreviation \$(ProjectAbbreviation) -environmentAbbreviation \$(EnvironmentAbbreviation) -appServicePlanAbbreviation \$(AppServicePlanAbbreviation) -logicAppAbbreviation \$(LogicAppAbbreviation) -serviceBusNamespaceAbbreviation \$(ServiceBusNamespaceAbbreviation) -serviceBusQueueAbbreviation \$(ServiceBusQueueAbbreviation) -scanAppServicePlanLocation \$(ScanAppServicePlanLocation) -scanAppServicePlanSKUName \$(ScanAppServicePlanSKUName) -scanAppServicePlanSKUTier \$(ScanAppServicePlanSKUTier) -scanAppServicePlanNumberOfWorkers \$(ScanAppServicePlanNumberOfWorkers) -hockeyAppAPIUri \$(HockeyAppAPIUri) -hockeyAppAPIAuthenticationTenant \$(HockeyAppAPIAuthenticationTenant) -hockeyAppAPIAuthenticationAudience \$(HockeyAppAPIAuthenticationAudience) -hockeyAppAPIAuthenticationClientId \$(HockeyAppAPIAuthenticationClientId) -hockeyAppAPIAuthenticationSecret \$(HockeyAppAPIAuthenticationSecret) -hockeyAppAPIPollingInterval \$(HockeyAppAPIPollingInterval) -scanQueueNamespaceKind \$(ScanQueueNamespaceKind) -scanQueueNamespaceSkuName \$(ScanQueueNamespaceSkuName) -scanQueueNamespaceSkuTier \$(ScanQueueNamespaceSkuTier) -scanQueueNamespaceLocation \$(ScanQueueNamespaceLocation) -scanQueueNamespaceAuthorizationRulesLocation \$(ScanQueueNamespaceAuthorizationRulesLocation)`;
const subst = `${pair}\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);