import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?'pair'(?'d'-)(?'lcv'\\w+)(?'s'\\s)(?'dol'\\$)(?'o'\\()(?'ucv'\\w+)(?'c'\\)))(?'es'\\s?)";
final String string = "-solutionName $(SolutionName) -solutionAbbreviation $(SolutionAbbreviation) -projectName $(ProjectName) -projectAbbreviation $(ProjectAbbreviation) -environmentAbbreviation $(EnvironmentAbbreviation) -appServicePlanAbbreviation $(AppServicePlanAbbreviation) -logicAppAbbreviation $(LogicAppAbbreviation) -serviceBusNamespaceAbbreviation $(ServiceBusNamespaceAbbreviation) -serviceBusQueueAbbreviation $(ServiceBusQueueAbbreviation) -scanAppServicePlanLocation $(ScanAppServicePlanLocation) -scanAppServicePlanSKUName $(ScanAppServicePlanSKUName) -scanAppServicePlanSKUTier $(ScanAppServicePlanSKUTier) -scanAppServicePlanNumberOfWorkers $(ScanAppServicePlanNumberOfWorkers) -hockeyAppAPIUri $(HockeyAppAPIUri) -hockeyAppAPIAuthenticationTenant $(HockeyAppAPIAuthenticationTenant) -hockeyAppAPIAuthenticationAudience $(HockeyAppAPIAuthenticationAudience) -hockeyAppAPIAuthenticationClientId $(HockeyAppAPIAuthenticationClientId) -hockeyAppAPIAuthenticationSecret $(HockeyAppAPIAuthenticationSecret) -hockeyAppAPIPollingInterval $(HockeyAppAPIPollingInterval) -scanQueueNamespaceKind $(ScanQueueNamespaceKind) -scanQueueNamespaceSkuName $(ScanQueueNamespaceSkuName) -scanQueueNamespaceSkuTier $(ScanQueueNamespaceSkuTier) -scanQueueNamespaceLocation $(ScanQueueNamespaceLocation) -scanQueueNamespaceAuthorizationRulesLocation $(ScanQueueNamespaceAuthorizationRulesLocation)";
final String subst = "${pair}\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}