# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?'pair'(?'d'-)(?'lcv'\w+)(?'s'\s)(?'dol'\$)(?'o'\()(?'ucv'\w+)(?'c'\)))(?'es'\s?)/${pair}\n/g;t' <<< "-solutionName $(SolutionName) -solutionAbbreviation $(SolutionAbbreviation) -projectName $(ProjectName) -projectAbbreviation $(ProjectAbbreviation) -environmentAbbreviation $(EnvironmentAbbreviation) -appServicePlanAbbreviation $(AppServicePlanAbbreviation) -logicAppAbbreviation $(LogicAppAbbreviation) -serviceBusNamespaceAbbreviation $(ServiceBusNamespaceAbbreviation) -serviceBusQueueAbbreviation $(ServiceBusQueueAbbreviation) -scanAppServicePlanLocation $(ScanAppServicePlanLocation) -scanAppServicePlanSKUName $(ScanAppServicePlanSKUName) -scanAppServicePlanSKUTier $(ScanAppServicePlanSKUTier) -scanAppServicePlanNumberOfWorkers $(ScanAppServicePlanNumberOfWorkers) -hockeyAppAPIUri $(HockeyAppAPIUri) -hockeyAppAPIAuthenticationTenant $(HockeyAppAPIAuthenticationTenant) -hockeyAppAPIAuthenticationAudience $(HockeyAppAPIAuthenticationAudience) -hockeyAppAPIAuthenticationClientId $(HockeyAppAPIAuthenticationClientId) -hockeyAppAPIAuthenticationSecret $(HockeyAppAPIAuthenticationSecret) -hockeyAppAPIPollingInterval $(HockeyAppAPIPollingInterval) -scanQueueNamespaceKind $(ScanQueueNamespaceKind) -scanQueueNamespaceSkuName $(ScanQueueNamespaceSkuName) -scanQueueNamespaceSkuTier $(ScanQueueNamespaceSkuTier) -scanQueueNamespaceLocation $(ScanQueueNamespaceLocation) -scanQueueNamespaceAuthorizationRulesLocation $(ScanQueueNamespaceAuthorizationRulesLocation)"