// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"" [0-9.]*""#).unwrap();
let string = "\"213\"sdasd \" 234.34\"dasd \"23.567222 \" dasd as\"123\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}