$re = '/" [0-9.]*"/';
$str = '"213"sdasd " 234.34"dasd "23.567222 " dasd as"123"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);