package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`" [0-9.]*"`)
var str = `"213"sdasd " 234.34"dasd "23.567222 " dasd as"123"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}