using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @""" [0-9.]*""";
string input = @"""213""sdasd "" 234.34""dasd ""23.567222 "" dasd as""123""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}