re = /([0-9]+).([0-9])+.([0-9])+.([0-9])+.([0-9])+.([0-9])+.([0-9])+.([0-9])+./
str = '23792.69307 90004.787348 07000.925607 7 90010000100000'
# Print the match result
str.match(re) do |match|
puts match.to_s
end