import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]+).([0-9])+.([0-9])+.([0-9])+.([0-9])+.([0-9])+.([0-9])+.([0-9])+.";
final String string = "23792.69307 90004.787348 07000.925607 7 90010000100000";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}