const regex = /([0-9]+).([0-9])+.([0-9])+.([0-9])+.([0-9])+.([0-9])+.([0-9])+.([0-9])+./;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]+).([0-9])+.([0-9])+.([0-9])+.([0-9])+.([0-9])+.([0-9])+.([0-9])+.', '')
const str = `23792.69307 90004.787348 07000.925607 7 90010000100000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}