// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<i class="fa[sb] fa-([\w\-]*)"(><\/i>|\s?\/>)"#).unwrap();
let string = "<i class=\"fas fa-disease\"></i>
<i class=\"fas fa-disease-ball-asdl\"/>
<i class=\"fas fa-disease-ball-alt\"/>
<i class=\"fas fa-disease\" /> ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}