const regex = /<i class="fa[sb] fa-([\w\-]*)"(><\/i>|\s?\/>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<i class="fa[sb] fa-([\\w\\-]*)"(><\\\/i>|\\s?\\\/>)', 'gm')
const str = `<i class="fas fa-disease"></i>
<i class="fas fa-disease-ball-asdl"/>
<i class="fas fa-disease-ball-alt"/>
<i class="fas fa-disease" /> `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}