$re = '/<i class="fa[sb] fa-([\w\-]*)"(><\/i>|\s?\/>)/m';
$str = '<i class="fas fa-disease"></i>
<i class="fas fa-disease-ball-asdl"/>
<i class="fas fa-disease-ball-alt"/>
<i class="fas fa-disease" /> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);