#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<i class="fa[sb] fa-([\w\-]*)"(><\/i>|\s?\/>)"
Local $sString = "<i class="fas fa-disease"></i>" & @CRLF & _
"<i class="fas fa-disease-ball-asdl"/>" & @CRLF & _
"<i class="fas fa-disease-ball-alt"/>" & @CRLF & _
"<i class="fas fa-disease" /> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")