# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(([0-9]{4})-(0[13578]|1[02])-(0[1-9]|[12][0-9]|3[01])|(0[469]|11)-((0[1-9]|[12][0-9]|30)|(02)-(0[1-9]|[12][0-9])))(([\s|T])(0[0-9]|1[0-9]|2[0-3]):(0[0-9]|[1-5][0-9])(:(0[0-9]|[1-5][0-9]))?(\.([0-9]{3}))?(Z)?)?"
test_str = ("2022-01-15\n"
"2022-01-15 12:07\n"
"2022-01-15T12:07\n"
"2022-01-15 12:07Z\n"
"2022-01-15T12:07Z\n"
"2022-01-15 12:07:30\n"
"2022-01-15T12:07:30\n"
"2022-01-15 12:07:30Z\n"
"2022-01-15T12:07:30Z\n"
"2022-01-15 12:07:30.286\n"
"2022-01-15T12:07:30.286\n"
"2022-01-15 12:07:30.286Z\n"
"2022-01-15T12:07:30.286Z\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.