const regex = /(([0-9]{4})-(0[13578]|1[02])-(0[1-9]|[12][0-9]|3[01])|(0[469]|11)-((0[1-9]|[12][0-9]|30)|(02)-(0[1-9]|[12][0-9])))(([\s|T])(0[0-9]|1[0-9]|2[0-3]):(0[0-9]|[1-5][0-9])(:(0[0-9]|[1-5][0-9]))?(\.([0-9]{3}))?(Z)?)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([0-9]{4})-(0[13578]|1[02])-(0[1-9]|[12][0-9]|3[01])|(0[469]|11)-((0[1-9]|[12][0-9]|30)|(02)-(0[1-9]|[12][0-9])))(([\\s|T])(0[0-9]|1[0-9]|2[0-3]):(0[0-9]|[1-5][0-9])(:(0[0-9]|[1-5][0-9]))?(\\.([0-9]{3}))?(Z)?)?', 'gm')
const str = `2022-01-15
2022-01-15 12:07
2022-01-15T12:07
2022-01-15 12:07Z
2022-01-15T12:07Z
2022-01-15 12:07:30
2022-01-15T12:07:30
2022-01-15 12:07:30Z
2022-01-15T12:07:30Z
2022-01-15 12:07:30.286
2022-01-15T12:07:30.286
2022-01-15 12:07:30.286Z
2022-01-15T12:07:30.286Z
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}