import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([0-9]{4})-(0[13578]|1[02])-(0[1-9]|[12][0-9]|3[01])|(0[469]|11)-((0[1-9]|[12][0-9]|30)|(02)-(0[1-9]|[12][0-9])))(([\\s|T])(0[0-9]|1[0-9]|2[0-3]):(0[0-9]|[1-5][0-9])(:(0[0-9]|[1-5][0-9]))?(\\.([0-9]{3}))?(Z)?)?";
final String string = "2022-01-15\n"
+ "2022-01-15 12:07\n"
+ "2022-01-15T12:07\n"
+ "2022-01-15 12:07Z\n"
+ "2022-01-15T12:07Z\n"
+ "2022-01-15 12:07:30\n"
+ "2022-01-15T12:07:30\n"
+ "2022-01-15 12:07:30Z\n"
+ "2022-01-15T12:07:30Z\n"
+ "2022-01-15 12:07:30.286\n"
+ "2022-01-15T12:07:30.286\n"
+ "2022-01-15 12:07:30.286Z\n"
+ "2022-01-15T12:07:30.286Z\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}