use strict;
my $str = '2022-01-15
2022-01-15 12:07
2022-01-15T12:07
2022-01-15 12:07Z
2022-01-15T12:07Z
2022-01-15 12:07:30
2022-01-15T12:07:30
2022-01-15 12:07:30Z
2022-01-15T12:07:30Z
2022-01-15 12:07:30.286
2022-01-15T12:07:30.286
2022-01-15 12:07:30.286Z
2022-01-15T12:07:30.286Z
';
my $regex = qr/(([0-9]{4})-(0[13578]|1[02])-(0[1-9]|[12][0-9]|3[01])|(0[469]|11)-((0[1-9]|[12][0-9]|30)|(02)-(0[1-9]|[12][0-9])))(([\s|T])(0[0-9]|1[0-9]|2[0-3]):(0[0-9]|[1-5][0-9])(:(0[0-9]|[1-5][0-9]))?(\.([0-9]{3}))?(Z)?)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}