// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<(.+?)\s*(.*?)\s*>(.+)<.+>|<\/?(\w+)\s*(.*?)\s*\/?>").unwrap();
let string = "<div>
`hello`
if (test) {
<p>ok</p>
}
else {
<a href=\"home\" >home</a>
<idfd dfd=\"href\" />
}
</div>
(<div>)
<>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}