using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(.+?)\s*(.*?)\s*>(.+)<.+>|<\/?(\w+)\s*(.*?)\s*\/?>";
string input = @"<div>
`hello`
if (test) {
<p>ok</p>
}
else {
<a href=""home"" >home</a>
<idfd dfd=""href"" />
}
</div>
(<div>)
<>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}