#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<(.+?)\s*(.*?)\s*>(.+)<.+>|<\/?(\w+)\s*(.*?)\s*\/?>"
Local $sString = "<div>" & @CRLF & _
" `hello`" & @CRLF & _
" if (test) {" & @CRLF & _
" <p>ok</p>" & @CRLF & _
" }" & @CRLF & _
" else {" & @CRLF & _
" <a href="home" >home</a>" & @CRLF & _
" <idfd dfd="href" />" & @CRLF & _
" }" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"(<div>)" & @CRLF & _
"<>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")