re = /<(.+?)\s*(.*?)\s*>(.+)<.+>|<\/?(\w+)\s*(.*?)\s*\/?>/
str = '<div>
`hello`
if (test) {
<p>ok</p>
}
else {
<a href="home" >home</a>
<idfd dfd="href" />
}
</div>
(<div>)
<>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end