re = /^([0-9]{3,6})$/m
str = '2250
22364
1245
5456454654654
5454
7898
11
1
454654654654654654
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end