import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]{3,6})$";
final String string = "2250\n"
+ "22364\n"
+ "1245\n"
+ "5456454654654\n"
+ "5454\n"
+ "7898\n"
+ "11\n"
+ "1\n"
+ "454654654654654654\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}