const regex = /^([0-9]{3,6})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([0-9]{3,6})$', 'gm')
const str = `2250
22364
1245
5456454654654
5454
7898
11
1
454654654654654654
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}