#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]{3,6})$"
Local $sString = "2250" & @CRLF & _
"22364" & @CRLF & _
"1245" & @CRLF & _
"5456454654654" & @CRLF & _
"5454" & @CRLF & _
"7898" & @CRLF & _
"11" & @CRLF & _
"1" & @CRLF & _
"454654654654654654" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")