// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(0*(25[0-5]|2[0-4]\d|[01]?\d\d?)\.){3}(0*(25[0-5]|2[0-4]\d|[01]?\d\d?))\b").unwrap();
let string = "1.1.1.1
2.2.2.2
10.10.10.10
100.100.100.100
125.125.125.125
250.250.250.250
255.255.255.255
0101.0101.0101.0101
00000102.00000102.00000102.00000102
0.0.0.0
256.256.256.256
1234.1234.1234.1234
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}