import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(0*(25[0-5]|2[0-4]\\d|[01]?\\d\\d?)\\.){3}(0*(25[0-5]|2[0-4]\\d|[01]?\\d\\d?))\\b";
final String string = "1.1.1.1\n"
+ "2.2.2.2\n"
+ "10.10.10.10\n"
+ "100.100.100.100\n"
+ "125.125.125.125\n"
+ "250.250.250.250\n"
+ "255.255.255.255\n"
+ "0101.0101.0101.0101\n"
+ "00000102.00000102.00000102.00000102\n"
+ "0.0.0.0\n\n"
+ "256.256.256.256\n"
+ "1234.1234.1234.1234\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}