use strict;
my $str = '1.1.1.1
2.2.2.2
10.10.10.10
100.100.100.100
125.125.125.125
250.250.250.250
255.255.255.255
0101.0101.0101.0101
00000102.00000102.00000102.00000102
0.0.0.0
256.256.256.256
1234.1234.1234.1234
';
my $regex = qr/\b(0*(25[0-5]|2[0-4]\d|[01]?\d\d?)\.){3}(0*(25[0-5]|2[0-4]\d|[01]?\d\d?))\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}