$re = '/.*(19[5-9][0-9]|[2-9][0-9]{3}).*/';
$str = 'File256name.txt
File307list.cvs
File2014text.xls';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);