const regex = /.*(19[5-9][0-9]|[2-9][0-9]{3}).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(19[5-9][0-9]|[2-9][0-9]{3}).*', 'g')
const str = `File256name.txt
File307list.cvs
File2014text.xls`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}