package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*(19[5-9][0-9]|[2-9][0-9]{3}).*`)
var str = `File256name.txt
File307list.cvs
File2014text.xls`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}