using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(19[5-9][0-9]|[2-9][0-9]{3}).*";
string input = @"File256name.txt
File307list.cvs
File2014text.xls";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}